Browser requirements for Ovid

Ovid web applications require the following minimum browsers:

  • Microsoft Internet Explorer 6.0 (for PCs only)
  • Netscape Navigator 7.0
  • Mozilla Firefox 1.0

Ovid recommends upgrading or switching your browser if neccessary to ensure that displays are optimal in the Ovid interface.

Ovid products require that JavaScript and Cookies are enabled.
Internet Explorer Javascript:

  • Tools > Internet Options > Security > Custom level > under Active Scripting, click Enable

Netscape Javascript:

  • Edit > Preferences > Advanced > click Enable Javascript > OK

The current browser versions are available from the following websites for download by PC and MAC users:

Ovid is committed to providing full support for Safari on the Ovid Online platform, to meet the needs of MAC users, but this is not yet available. For the most current information about supported browsers, see http://www.ovid.com/site/support/web_config.jsp